ELS - Easy Linux Security script

ELS stands for Easy Linux Security. ELS was created by the Server Monkeys Founder, Richard Gannon and Martynas Bendorius. ELS takes many of the tasks performed by our Administrators and puts it into an easy to use program for anyone to use. It is released under the GNU/GPL so it is free to use.

This program is always being improved with new features and bugfixes, so be sure to keep it up to date. If you found a bug or would like an improvement, please let us know! If you really like this program, donations are more than welcome!

Supported Operating Systems :

* Red Hat Linux 9
* Red Hat Enterprise Linux 3, 4
* Fedora Core 1, 2, 3, 4, 5 and 6
* CentOS 3, 4

What ELS Does:

* Install RKHunter
* Install RKHunter Cronjob which emails a user-set email address nightly
* Install/update APF
* Install/update BFD
* Install CHKROOTKIT
* Install CHKROOTKIT Cronjob which emails a user-set email address nightly
* Disable Telnet
* Force SSH Protocol 2
* Secure /tmp
* Secure /var/tmp
* Secure /dev/shm
* Install/update Zend Optimizer
* Install/update eAccelerator
* MySQL 4.1 and 5.0 Configuration Optimization
* Upgrade MySQL to 5.0
* Tweak WHM Settings for security and stability
* Configure RNDC if not already done (cPanel only)
* Change SSH port (also configure APF as necessary)
* Add wheel user and disable direct root login over SSH
* Optimize MySQL tables
* Install/update Libsafe
* Install/update ImageMagick (from latest source)
* Uninstall LAuS
* Harden sysctl.conf
* Install Chirpy's Free Exim Dictionary Attack ACL (cPanel only)
* And more!

To install ELS, simply run the following command as root:
# wget --output-document=installer.sh http://servermonkeys.com/projects/els/installer.sh; chmod +x installer.sh; sh installer.sh

  • Email, SSL
  • 0 Users Found This Useful
Was this answer helpful?

Related Articles

CSF (Config Server Firewall) Installation

Installation============Installation is quite straightforward:rm -fv csf.tgzwget...

CentOS 4 upgrade from MySQL 4 to MySQL 5

I've found that CentOS 4 is coming with MySQL 4.1 are not supporting their MySQL 5 in their...